You are here: TWiki> Online Web>UserSubversionLbgw (revision 2)
Tags:
create new tag
, view all tags
Upgrade of the default svn client to version 1.5.2 on lbgw0[1-2].

On lbgw01 and lbgw02, svn is now version 1.5.2. This tool is installed in the directory "/opt/CollabNet_Subversion/". In order to use this latest version by default, a link is set this way : "/usr/bin/svn -> /opt/CollabNet_Subversion/bin/svn".

If you wish to continue to use the version 1.4.4, it is possible using "/usr/bin/svn.old".

Since the default version of svn has been upgraded to 1.5, a problem can occur.

Symptom:

The full error message is: This client is too old to work with working copy '.'; please get a newer Subversion client.

You will get this error message once you have used a Subversion client linked with a higher Subversion version, and then try to execute a command with a Subversion client linked with an older version, e.g., you used an 1.5.x client on your working copy, and now you try an svn 1.4.x client on the same working copy.

Problem:

The reason for this is that Subversion 1.4 and 1.5 upgrade the working copies transparently on every command. But once the working copy format is upgraded, older clients can't access the working copy anymore because they don't know the new format.

Comment:

source : http://tortoisesvn.net/node/240

Mailing lists:

User mailing list : users@subversion.tigris.org

Release announcement : announce@subversion.tigris.org

-- JeanChristopheGarnier - 17 Oct 2008

Edit | Attach | PDF version | Print version |  | Raw View | Raw edit | Backlinks | History: r3 < r2 < r1 | More topic actions...
Topic revision: r2 - 2008-10-20 - jc
 

Edit Attach

TWIKI.NET
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2022 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback